Compusult Office - Power Outage
Incident Report for Compusult Pty Ltd
Resolved
This incident has been resolved.
Posted 8 months ago. Jan 25, 2019 - 15:22 AEDT
Investigating
Please be advised the state of Victoria is experiencing power outages which is affecting our office. Please note that we are currently running at limited capacity but will work with you to assist you during this time.
Posted 8 months ago. Jan 25, 2019 - 13:57 AEDT
This incident affected: Compusult Support (NOC) (NOC - Monitoring & Maintenance) and Compusult HelpDesk, Compusult Phone Support.