Tyro - Medicare Easy Claim Issues
Incident Report for Compusult Pty Ltd
Resolved
Tyro have advised the issues have now been resolved and to restart your Tyro unit to come back online.
Posted over 2 years ago. Jun 15, 2017 - 11:21 AEST
Investigating
We have had a number of clients call with Tyro issues. These issues are related to processing Medicare easy claims. Tyro are aware of the issue and are investigating. Further updates provided once they become available.
Posted over 2 years ago. Jun 15, 2017 - 10:52 AEST