Office 365 - Email Delays - Australian Tenants (EX196121)
Incident Report for Compusult Pty Ltd
Resolved
Email delivery has returned to normal.
Microsoft have reported that the issue was a result of a SPAM restriction policy introduced for Australian Tenants.
No further delays are expected.
Posted Nov 19, 2019 - 23:30 AEDT
Monitoring
We have reports of email delivery being delayed for some Office 365 tenants.

Microsoft have released an Incident Statement related to this issue (EX196121)

Quote:
---
Title: Problems receiving mail

User Impact: Users may not receive emails sent from external users.

More info: Messages sent internally between users are not impacted.

Current status: We suspect there is a networking issue that is causing impact. We're continuing our investigation of network logs.

Scope of impact: This issue could potentially impact any users receiving emails from external users.
---

No remediation works are required at this stage, however our technicians will continue to monitor this incident to ensure that services self recover.
Posted Nov 19, 2019 - 16:05 AEDT
This incident affected: Third Party Providers.