Emergency Power Outage
Incident Report for Compusult Pty Ltd
Resolved
Power has been restored and we are back to full operation. Our team are working through any calls / messages left.

Thank you to PowerCore & Watters Electrical for promptly attending to the issue and getting our lights back on.

Thanks also to all our clients - your patience and understanding during this incident was appreciated.
Posted Nov 08, 2023 - 15:57 AEDT
Identified
We wanted to inform you that we are currently experiencing a temporary power outage at our premises. Powercor is diligently working to repair our connection to the building, and we anticipate that our electricity supply will be restored as soon as possible.
During this outage, we sincerely apologise for any inconvenience you may experience. Please be aware that our helpdesk support will be limited while we await the restoration of power. Our team is doing their best to address urgent matters, but response times may be longer than usual.
Rest assured, we understand the importance of your inquiries and concerns, and we are committed to providing you with support. As soon as our power supply is back up and running, we will resume normal operations and respond promptly to any outstanding requests.
Thank you for your patience and understanding during this unexpected situation. We appreciate your continued support and look forward to serving you at full capacity once our power is restored.
Stay tuned for further updates, and feel free to reach out if you have any urgent matters that require immediate attention.
Posted Nov 08, 2023 - 12:47 AEDT
This incident affected: Compusult HelpDesk and Third Party Providers.